Pré-requisitos de servidor - Linux

Certifique-se de atender aos seguintes pré-requisitos para instalar o Servidor ESET PROTECT no Linux:

Você deve ter uma licença válida.

Você deve ter um sistema operacional Linux compatível.

As portas necessárias devem estar abertas e disponíveis – consulte a lista completa de portas aqui.

Um servidor do banco de dados deve ser instalado e configurado com uma conta de raiz. Uma conta de usuário não precisa ser criada antes da instalação. O instalador pode criar a conta. O MS SQL Server para Linux não é compatível. Mas você pode conectar o Servidor ESET PROTECT no Linux ao MS SQL Server no Windows.


note

O Servidor ESET PROTECT armazena grandes blocos de dados no banco de dados. Configure o MySQL para aceitar pacotes grandes para que o ESET PROTECT seja executado corretamente.

Unidade ODBC – A Unidade ODBC é usada para estabelecer conexão com o servidor de banco de dados (MySQL).

Defina o arquivo de instalação do servidor como um executável usando o comando Terminal:

chmod +x server-linux-x86_64.sh

Recomendamos que você use a versão mais recente do OpenSSL 1.1.1. O OpenSSL 3.x não é compatível. A versão mínima compatível do OpenSSL para Linux é openssl-1.0.1e-30. Podem existir mais versões do OpenSSL instaladas em um sistema simultaneamente. Pelo menos uma versão compatível deve estar presente no seu sistema.

oUse o comando openssl version para exibir sua versão padrão atual.

oVocê pode listar todas as versões do OpenSSL presentes no seu sistema. Veja as terminações de nome de arquivo listadas usando o comando sudo find / -iname *libcrypto.so*

oVocê pode verificar se seu cliente Linux é compatível usando o comando a seguir: openssl s_client -connect google.com:443 -tls1_2

Xvfb - Necessário para a impressão correta de relatórios (Gerar relatório) em sistemas de servidor Linux sem uma interface gráfica.

Xauth – o pacote é instalado junto com o xvfb. Você precisa instalar o xauth se não instalar o xvfb.

cifs-utils – Necessário para implantação apropriada do Agente para um sistema operacional Windows.

Bibliotecas Qt4 WebKit - Usado para impressão de relatórios no formato PDF e PS (deve ser a versão 4.8, e não 5). Todas as outras dependências Qt4 serão instaladas automaticamente. Se o pacote não estiver disponível em você no repositório do sistema operacional, você poderá compilar você mesmo em uma máquina de destino ou instalar de um repositório de terceiros (por exemplo, repositórios EPEL): Instruções do CentOS 7, instruções do Ubuntu 20.04.

kinit + klist – o Kerberos é usado para autenticar um usuário do domínio durante a tarefa de login e sincronização do Active Directory. Certifique-se de configurar o Kerberos adequadamente (/etc/krb5.conf). ESET PROTECT 9.1 é compatível com a sincronização com vários domínios.

ldapsearch – Usado na tarefa de sincronização AD e para autorização.

snmptrap – opcional, usado para enviar intercepções SNMP. O SNMP também requer configuração.

Pacote SELinux devel - Usado durante a instalação do produto para construir módulos de política SELinux. Isso só é necessário em sistemas com SELinux ativado (CentOS, RHEL). SELinux pode causar problemas com outros aplicativos. Para um Servidor ESET PROTECT isso não é necessário.

lshw - Instale o pacote lshw na máquina Linux do cliente/servidor para que o Agente ESET Management reporte o inventário de hardware corretamente.

A tabela abaixo contém os comandos de terminais adequados para cada pacote descrito acima para várias distribuições Linux (execute os comandos como sudo ou root):

Pacote

Distribuições Debian e Ubuntu

Distribuições CentOS e Red Hat

Distribuição OpenSUSE

Unidade ODBC

Consulte o capítulo Instalação e configuração ODBC.

OpenSSL

apt-get install openssl

yum install openssl -y

zypper install openssl

xvfb

apt-get install xvfb

yum install xorg-x11-server-Xvfb -y

zypper install xorg-x11-server-extra

cifs-utils

apt-get install cifs-utils

yum install cifs-utils

zypper install cifs-utils

Bibliotecas Qt4 WebKit

apt-get install libqtwebkit4

Veja as instruções para o Ubuntu 20.04.

O Qt4 WebKit não está no repositório CentOS padrão. Instale esses pacotes:

yum install -y epel-release

yum install qtwebkit-devel

Alternativamente, você pode instalar o pacote de repositórios Fedora.

zypper install libqtwebkit4

kinit+klist – opcional (necessário para o serviço do Active Directory)

apt-get install krb5-user

yum install krb5-workstation

zypper install krb5-client

ldapsearch

apt-get install ldap-utils
libsasl2-modules-gssapi-mit

yum install openldap-clients
cyrus-sasl-gssapi cyrus-sasl-ldap -y

zypper install openldap2-client
cyrus-sasl-gssapi
cyrus-sasl-ldap-auxprop

snmptrap

apt-get install snmp

yum install net-snmp-utils net-snmp

zypper install net-snmp

Pacote SELinux devel (opcional – não é necessário para o Servidor ESET PROTECT; SELinux pode causar problemas com outros aplicativos.)

apt-get install selinux-policy-dev

yum install policycoreutils-devel

zypper install selinux-policy-devel

samba (opcional, necessário apenas para a implantação remota)

apt-get install samba

yum install samba
samba-winbind-clients

zypper install samba samba-client

lshw

apt-get install -y lshw

yum install -y lshw

zypper install lshw