Supported versions of Apache Tomcat and Java

Apache Tomcat

Apache Tomcat is a mandatory component required to run the ESET PROTECT Web Console.

ESET PROTECT supports only Apache Tomcat 9.x (64-bit). We recommend that you use the latest Apache Tomcat 9.x.

ESET PROTECT does not support alpha/beta/RC versions of Apache Tomcat.

Java

Apache Tomcat requires 64-bit Java/OpenJDK.

If you have multiple Java versions installed on your system, we recommend uninstalling earlier Java versions and keeping only the latest supported Java version.


warning

Starting January 2019, Oracle JAVA SE 8 public updates for business, commercial or production use require a commercial license. If you do not purchase a JAVA SE subscription, you can transition to a no-cost alternative. See the supported versions of JDK.