Requisitos previos del servidor: Linux

Se deben cumplir los siguientes requisitos previos para poder instalar el Servidor ESET PROTECT en Linux:

Debe tener una licencia válida.

Debe tener un sistema operativo Linux compatible.

Los puertos necesarios deben estar abiertos y disponibles: consulte la lista completa de puertos aquí.

Debe tener un servidor de la base de datos debe estar instalado y configurado con una cuenta raíz. No tiene que crear una cuenta de usuario antes de la instalación. El instalador puede crear la cuenta. MS SQL Server en Linux no es compatible. Sin embargo, puede conectar el servidor de ESET PROTECT en Linux con el Servidor MS SQL en Windows.


note

El servidor de ESET PROTECT almacena grandes blobs de datos en la base de datos. Configure MySQL para aceptar paquetes grandes para que ESET PROTECT se ejecute correctamente.

Controlador ODBC: el controlador ODBC se usa para establecer la conexión con el servidor de base de datos (MySQL).

Configure el archivo de instalación del servidor configurado como ejecutable. Para hacerlo, use el siguiente comando de terminal:

chmod +x server-linux-x86_64.sh

Se recomienda usar la versión más reciente de OpenSSL (1.1.1). La versión mínima compatible de OpenSSL es openssl-1.0.1e-30. Puede haber más versiones de OpenSSL instaladas en un sistema al mismo tiempo. Debe haber al menos una versión compatible presente en su sistema.

oPuede usar el comando openssl version para mostrar la versión predeterminada actual.

oPuede mostrar una lista de todas las versiones de OpenSSL presentes en su sistema. Vea las extensiones de nombre de archivo con el comando sudo find / -iname *libcrypto.so*

Xvfb - Necesario para una adecuada impresión de informes (Generar informe) en los sistemas Linux Server sin una interfaz gráfica.

Xauth: el paquete se instala junto con xvfb. Debe instalar xauth si no instala xvfb.

cifs-utils: se requiere para una implementación adecuada del agente en un sistema operativo Windows.

Bibliotecas Qt4 WebKit - se usan para imprimir informes en formato PDF y PS (deben ser versión 4.8, no 5). Todas las demás dependencias Qt4 se instalarán automáticamente. Si el paquete no está disponible en el repositorio de su sistema operativo, puede compilarlo usted mismo en el equipo de destino o instalarlo en el repositorio de un tercero (por ejemplo, los repositorios EPEL): Instrucciones de CentOS 7, instrucciones de Ubuntu 20.04.

kinit + klist: Kerberos se usa para la autenticación de un usuario de dominio al iniciar sesión y la tarea de sincronización con Active Directory. Asegúrese de que su Kerberos se haya configurado correctamente (/etc/krb5.conf). ESET PROTECT 9.0. es compatible con la sincronización con múltiples dominios.

ldapsearch: se usa en la tarea de sincronización de AD y para autorización.

snmptrap: se usa para enviar capturas SNMP. Si no usará esta funcionalidad, es opcional. SNMP también necesita una configuración.

Paquete SELinux devel - usado durante la instalación del producto para desarrollar módulos de políticas SELinux. Solo es obligatorio en sistemas con SELinux habilitado (CentOS, RHEL). SELinux puede generar problemas con otras aplicaciones. En el caso del Servidor ESET PROTECT, no es necesario.

lshw - Instale el paquete lshw en el equipo cliente/servidor Linux para que el agente ESET Management informe correctamente del inventario de hardware.

La tabla a continuación contiene los comandos de terminal adecuados para cada paquete descrito anteriormente para diversas distribuciones de Linux (ejecute los comandos como sudo o root):

Paquete

Distribuciones Debian y Ubuntu

Distribuciones CentOS y Red Hat

Distribución OpenSUSE

Controlador ODBC

Consulte el capítulo Instalación y configuración de ODBC.

xvfb

apt-get install xvfb

yum install xorg-x11-server-Xvfb

zypper install xorg-x11-server-extra

cifs-utils

apt-get install cifs-utils

yum install cifs-utils

zypper install cifs-utils

Bibliotecas Qt4 WebKit

apt-get install libqtwebkit4

Consulte las instrucciones de Ubuntu 20.04.

Consulte nuestro artículo de la base de conocimiento.

zypper install libqtwebkit4

kinit + klist: opcional (necesario para el servicio Active Directory)

apt-get install krb5-user

yum install krb5-workstation

zypper install krb5

ldapsearch

apt-get install ldap-utils
libsasl2-modules-gssapi-mit

yum install openldap-clients
cyrus-sasl-gssapi cyrus-sasl-ldap

zypper install openldap2-client
cyrus-sasl-gssapi
cyrus-sasl-ldap-auxprop

snmptrap

apt-get install snmp

yum install net-snmp-utils net-snmp

zypper install net-snmp

Paquete de SELinux devel (opcional: no es necesario para el servidor de ESET PROTECT; SELinux puede causar problemas con otras aplicaciones.)

apt-get install selinux-policy-dev

yum install policycoreutils-devel

zypper install selinux-policy-devel

samba (opcional, necesario únicamente para la implementación remota)

apt-get install samba

yum install samba
samba-winbind-clients

zypper install samba samba-client

lshw

apt-get install -y lshw

yum install -y lshw

zypper install lshw