Agent prerequisites - Linux

The following prerequisites must be met in order to install the ESET Management Agent component on Linux:

We recommend that you use the latest OpenSSL version (1.1.1). The minimum supported version of OpenSSL is openssl-1.0.1e-30. There can be more versions of OpenSSL installed on one system in the same time. At least one supported version must be present on you system.

oYou can use the command openssl version to show current default version.

oYou can list all versions of OpenSSL present on your system. See the filename endings listed using the command sudo find / -iname *libcrypto.so*

Install the lshw package on the client/server Linux machine for the ESET Management Agent to report the hardware inventory correctly.

 

Linux distribution

Terminal command

Debian, Ubuntu

sudo apt-get install -y lshw

Red Hat, CentOS, RHEL

sudo yum install -y lshw

OpenSUSE

sudo zypper install lshw

 

For Linux CentOS it is recommended to install the policycoreutils-devel package. Run the command to install the package:

yum install policycoreutils-devel

Server-assisted Agent installation:

The server computer must be reachable from the network and have ESET PROTECT Server and ESET PROTECT Web Console installed

Offline Agent installation:

The server computer must be reachable from the network and have ESET PROTECT Server installed

A Certificate for the Agent must be present

A server Certification Authority public key file must be present