Troubleshooting - Web Console
The table below will give you some insight into the most common Web Console login error massages and statuses, what they mean and some additional troubleshooting steps:
Error message |
Possible cause |
---|---|
Login failed: Invalid username or password |
Make sure that you typed your username and password correctly. You can reset the ESET PROTECT Web Console password. |
Login failed: Connection has failed with state 'Not connected' |
Check to see whether the ESET PROTECT Server service and your database service are running, see our Knowledgebase article for step-by-step instructions. |
Login failed: User was blocked. Please try again later. |
After 10 unsuccessful login attempts from the same IP address (for example, using incorrect login credentials), further login attempts from this IP address are temporarily blocked. After 10 minutes, log in using the correct credentials. |
Login failed: Communication error |
Verify that the ESET PROTECT Server service is running and Apache Tomcat service is running and working properly. Review the log files for Apache Tomcat. See our Knowledgebase article for more information on this issue. |
Login failed: Connection timeout |
Check network connection and firewall settings to make sure ESET PROTECT Web Console can reach ESET PROTECT Server. Also, ESET PROTECT Server may be overloaded, attempt to reboot it. This issue can also occur if you are using different versions of ESET PROTECT Web Console and ESET PROTECT Server. |
Login failed: User has no access rights assigned |
The user does not have any access rights assigned. Log in as an administrator and edit the user's account so that they have at least one Permission Set assigned. |
Login failed: Response parsing error |
Your version of Web Console and ESET PROTECT Server are not compatible. This can happen during or after components upgrade. If the problem persists, deploy the correct version of the Web Console manually. |
Using unencrypted connection! Please configure the webserver to use HTTPS |
For security reasons, we recommend that you set up ESET PROTECT Web Console to use HTTPS. |
JavaScript is disabled. Please enable JavaScript in your browser. |
Enable JavaScript or update your web browser. |
SEC_ERROR_INADEQUATE_KEY_USAGE (Mozilla Firefox only). |
Mozilla Firefox has a corrupted certificate store. |
Error |
Possible cause |
---|---|
You do not see the login screen or the login screen appears to be constantly loading. |
•Restart the ESET PROTECT Server service. When the ESET PROTECT Server service is up and running again, restart the Apache Tomcat service. After this, the ESET PROTECT Web Console login screen will load successfully. Read also our Knowledgebase article. •If Apache Tomcat is not able to extract content from era.war file and Web Console is not accessible, follow the steps in our Knowledgebase article. |
The text is missing in the context menu and Quick Links menu in ESET PROTECT Web Console. |
This issue may be caused by an ad-blocking browser extension. To solve this issue, disable ad-blocking browser extension for ESET PROTECT Web Console page. |
After login, the Web Console is not correctly displayed (missing elements, etc.). |
Make sure you are using a supported web browser. |
After login, some Web Console screens do not load. |
If some of the ESET PROTECT Web Console screens (e.g. Computers) do not load, open the Tomcat9w.exe file located in C:\Program Files\Apache Software Foundation\[Tomcat folder ]\ •In the General tab, click Stop to stop the Apache Tomcat service. •Select the Java tab and add the following code under Java Options: •In the General tab, click Start to start the Apache Tomcat service. |
The Web Console takes a long time to load. When loading a large number of objects, the console crashes. |
The Web Console requires additional memory when handling large object sets. See the Web Console for enterprise settings. |
Some screens in the Web Console do not load correctly and you see an error. For example, when editing a policy, you see the error: "ERROR WHILE INITIALIZING CONFIGURATION EDITOR.: (TYPEERROR) : ((INTERMEDIATE VALUE)(INTERMEDIATE VALUE) , K).INITCONFIGEDITOR IS NOT A FUNCTION" |
This issue occurs if you are using a reverse proxy that prevents some Web Console modules from loading. The URL strings for individual Web Console modules (loaded in Apache Tomcat) may dynamically change (for example, the string after era/webconsole/configEngine/ in era/webconsole/configEngine/02645EFC6ABCDE2B449042FB8S63FD3/v0.0/css/001_ce.ltr.css). To solve the issue, make sure to properly configure your reverse proxy. |
When importing a large (over 20 MB) file (e.g. a policy) the process fails. |
The file size limit for Web Console is 20 MB. You can change it by editing the EraWebServerConfig.properties file, located in the [Tomcat folder]\webapps\era\WEB-INF\classes\sk\eset\era\g2webconsole\server\modules\config\ folder. Change the file_size_limit=20 to a higher value, the maximum value is 250. |
• After upgrading ESET PROTECT, we recommend that you delete the web browser cache and cookies before logging into the upgraded Web Console. •Since the Web Console uses secure protocol (HTTPS), you might get a message in your web browser regarding a security certificate or untrusted connection (exact wording of the message depends on the browser you are using). This is because your browser wants you to verify the identity of the site you are trying to access. Click Advanced > Continue to [address] (unsafe) (Chrome/Edge) or Advanced > Accept the Risk and Continue (Firefox) to allow access to the ESET PROTECT Web Console. This only applies when you are trying to access the ESET PROTECT Web Console URL. Read our Knowledgebase article for more information on how to set up HTTPS/SSL connection. |