行動裝置連接器先決條件 - Linux

必須符合下列先決條件才能將行動裝置連接器安裝在 Linux 上:

已使用根帳戶身分安裝與配置資料庫伺服器 (安裝前不一定要先建立使用者帳戶,安裝程式會建立帳戶)。

用於連線至資料庫伺服器 (MySQL / MS SQL) 的 ODBC 驅動程式已安裝在電腦上。請參閱 ODBC 安裝與配置一章。

note

注意

您應使用 unixODBC_23 套件 (非預設 unixODBC),使 MDC 能正確連接至 MySQL 資料庫。這特別適用於 SUSE Linux。

note

注意

我們建議您將 MDM 元件部署在與託管 ESMC 伺服器的不同主機裝置上。

MDMCore 安裝檔設定為執行檔。

chmod +x mdmcore-linux-x86_64.sh

安裝後請確認 MDMCore 服務正在執行。

service eramdmcore status

我們建議您使用最新的 OpenSSL 版本 (1.1.1)。最低支援的 OpenSSL 版本為 openssl-1.0.1e-30。可以有多種版本的 OpenSSL 同時安裝在一個系統上。您的系統上必須至少有一個支援的版本。

o您可以使用命令 openssl version 來顯示目前的預設版本。

o您可以列出存在於您系統上所有版本的 OpenSSL。請參閱使用命令 sudo find / -iname *libcrypto.so* 列出的檔案名稱結尾

oFedora Linux 使用者應使用 compat-openssl10 套件。

note

注意

如果您在 MySQL 上的 MDM 資料庫過大 (有數千個裝置),則預設的 innodb_buffer_pool_size 值會過小。如需資料庫最佳化的詳細資訊,請參閱:https://dev.mysql.com/doc/refman/5.6/en/optimizing-innodb-diskio.html

憑證需求

您將會需要 .pfx格式的 SSL 憑證,來保護透過 HTTPS 通訊的安全。我們建議您使用憑證授權單位 (ESMC CA 或第三方 CA) 提供的憑證。同時不建議使用自我簽署憑證,因為並非所有的行動裝置都能讓使用者接受自我簽署憑證。但 CA 簽署憑證並沒有這個問題,因為這些是受信任的憑證,且不需要使用者接受。

您必須具備 CA 簽署的憑證 (ESMC CA 或第三方 CA),以及對應的私密金鑰,並使用標準程序 (傳統上使用 OpenSSL),才能將那些項目合併為一個 .pfx 檔案:
openssl pkcs12 -export -in certificate.cer -inkey privateKey.key -out httpsCredentials.pfx
這是標準程序,適用於多數使用 SSL 憑證的伺服器。

對於離線安裝,您也將會需要對等憑證 (透過 ESET Security Management Center 匯出代理程式憑證)。或者,您可以使用自訂憑證與 ESMC 搭配。