元件升級工作

本章包含下列數節:

建議

已升級的元件清單

升級前

Remote Administrator 元件升級工作程序

疑難排解

 

建議:

我們建議使用 ERA Web Console 中提供的 [元件升級] 工作,來升級您的 ERA 基礎架構。下列範例告訴您如何設定 [Remote Administrator 元件升級] 工作,以從 ERA 6.1.x 或更新版本升級到 ERA 6.5 版。

validation-status-icon-warning 重要:備份所有憑證 (憑證授權單位、伺服器憑證、Proxy 和代理程式憑證),才能執行此作業。若要備份您的憑證:

1.將您的憑證授權單位憑證從舊 ERA 伺服器匯出至 .der檔案,並儲存至外部儲存裝置。

2.您的對等憑證 (適用於 ERA 代理程式、ERA 伺服器、ERA Proxy) 和私密金鑰從 ERA 伺服器匯出至 .pfx 檔案,並儲存至外部儲存裝置。

執行此工作時,強烈建議您選取 [全部] 作為目標,以確保整個 ERA 基礎架構都會升級。

 

已升級的元件清單:

ERA 伺服器

ERA 代理程式 (如果已選取網路中所有已安裝 ERA 代理程式的電腦作為工作目標,則工作將更新所有電腦)

ERA Proxy

ERA Web Console (僅在使用 ERA 全方位安裝程式或 ERA 虛擬設備和任何 Linux 發送安裝時適用 [這些發送於下列安裝資料夾中提供: /var/lib/tomcat8/webapps/, /var/lib/tomcat7/webapps/, /var/lib/tomcat6/webapps/, /var/lib/tomcat/webapps/])

ERA 行動裝置連接器 (從 6.2.11.0 版到 ERA 6.5 版)

下列元件必須手動升級:

Apache Tomcat (強烈建議您保持最新的 Apache Tomcat,請參閱升級 Apache Tomcat)

Apache HTTP Proxy (可以使用全方位安裝程式來完成,請參閱升級 Apache HTTP Proxy)

ERA Rogue Detection Sensor

 

升級前:

validation-status-icon-error 如果在執行 ERA 伺服器或 Web Console 的電腦上元件升級失敗,您可能無法遠端登入 Web Console。建議您先配置實體存取至伺服器電腦,然後再執行這項升級。如果您無法配置電腦的實體存取,請確保您可以使用遠端桌面,透過管理員權限登入該電腦。建議您先備份您的 ERA 伺服器和行動裝置連接器資料庫,然後再執行此作業。若要備份您的虛擬設備,請建立快照或複製您的虛擬設備。

hmtoggle_plus0從 ERA 6.1.x 版升級嗎?
hmtoggle_plus0ERA 伺服器執行個體是否安裝在容錯移轉叢集上?
hmtoggle_plus0在您基礎架構中執行 systemd 的 Linux 用戶端上是否安裝了 ERA 代理程式?
hmtoggle_plus0在 Microsoft Windows 上升級 Apache HTTP Proxy 前的重要指示
hmtoggle_plus0在虛擬設備上升級 Apache HTTP Proxy 前的重要指示

 

請參閱 Remote Administrator 元件升級工作程序線上說明主題。如需將 ESET Remote Administrator 升級為最新版本 (6.x) 的其他指南,請參閱我們的知識庫文章

 

疑難排解:

確認您是否可從升級的電腦存取 ERA 存放庫

如果有至少一個元件已經升級為更新版本,則無法重新執行 Remote Administrator 元件升級工作。

如果不清楚失敗的原因,請手動升級元件。請參閱針對 WindowsLinux 的指示。

如果在 Linux 電腦上使用 systemd 作為服務管理員,這個工作可能無法成功完成。具有 SysV 初始化指令碼upstart 的 Linux 發送皆不受影響。

如需解決升級問題的其他建議,請參閱一般疑難排解資訊