Requisitos previos del servidor - Linux

Se deben cumplir los siguientes requisitos para instalar ERA Server en Linux:

Debe disponer de una licencia válida.

Debe instalarse un servidor de bases de datos y configurarse con una cuenta raíz. No es necesario crear una cuenta de usuario antes de la instalación, el instalador puede crear la cuenta.
validation-status-icon-infoNOTA: ERA Server almacena grandes blobs de datos en la base de datos, por lo que para que ERA se ejecute correctamente, es necesario configurar MySQL de forma que acepte paquetes de gran tamaño.

Controlador de ODBC: el controlador de ODBC se utiliza para establecer conexión con el servidor de la base de datos (MySQL / MS SQL).

Configure el archivo de instalación del servidor establecido como un ejecutable. Para hacer esto, utilice el siguiente comando de terminal:

chmod +x Server-Linux-x86_64.sh

La versión mínima compatible de openSSL es openssl-1.0.1e-30 (el comando openssl version muestra la versión actual)

Xvfb: se requiere para la impresión correcta del informe (Generar informe) en los sistemas de servidor Linux sin una interfaz gráfica.

Cifs-utils: se requiere para la implementación del agente en un Windows OS.

Bibliotecas Qt4 WebKit: se utilizan para la impresión de informes en formato PDF y PS (debe ser la versión 4.8, no la 5). El resto de dependencias Qt4 se instalarán automáticamente. En el caso de CentOS, el paquete podría no estar en los repositorios oficiales. Puede instalarlo desde el repositorio de un tercero (por ejemplo los repositorios EPEL) o compilarlo usted mismo en el equipo de destino.

Kinit + klist: se usa para la autenticación Kerberos durante la tarea de sincronización de AD y el inicio de sesión con un usuario de dominio. Se requiere también una configuración de Kerberos adecuada (/etc/krb5.conf).

Wbinfo + ntlm auth: se utiliza para autenticación con las cuentas de dominio + autenticación NTLM con servidor SMTP (envío de correos electrónicos).

Ldapsearch: se utiliza para la tarea de sincronización de AD.

Snmptrap: se utiliza para enviar capturas de SNMP. Opcional si no se desea utilizar esta funcionalidad. SNMP también requiere configuración.

Paquete SELinux devel: se utiliza durante la instalación del producto para crear módulos de política de SELinux. Solo se requiere en sistemas con SELinux activado (CentOS, Fedora, RHEL). SELinux podría provocar problemas con otras aplicaciones. En el caso de ERA Server no es necesario.

 

En la siguiente tabla se incluyen los comandos de terminal adecuados para cada paquete descrito anteriormente para las distribuciones Debian, Ubuntu, Centos, Red Hat y Fedora:

Distribuciones de Debian y Ubuntu

Distribuciones CentOS, Red Hat y Fedora

OpenSUSE distribution

Controlador ODBC

apt-get install unixodbc
libmyodbc

yum install mysql-connector-odbc

zypper install unixodbc
myodbc-unixbox

xvfb

apt-get install xvfb

yum install xorg-x11-server-Xvfb

zypper install xorg-x11-server-extra

cifs-utils

apt-get install cifs-utils

yum install cifs-utils

zypper install cifs-utils

Bibliotecas Qt4 WebKit

apt-get install libqtwebkit4

Consulte nuestro artículo de la base de conocimiento.

zypper install libqtwebkit4

kinit+klist opcional (se necesita para el servicio Active Directory)

apt-get install krb5-user

yum install krb5-workstation

zypper install krb5

wbinfo + ntlm_auth

apt-get install winbind

yum install samba-winbind-clients

zypper install samba-winbind

ldapsearch

apt-get install ldap-utils
libsasl2-modules-gssapi-mit

yum install openldap-clients
cyrus-sasl-gssapi cyrus-sasl-ldap

zypper install openldap2-client
cyrus-sasl-gssapi
cyrus-sasl-ldap-auxprop

snmptrap

apt-get install snmp

yum install net-snmp-utils net-snmp

zypper install net-snmp

Paquete SELinux devel (opcional; SELinux podría provocar problemas con otras aplicaciones. En el caso de ERA Server no es necesario).

apt-get install selinux-policy-dev

yum install policycoreutils-devel

zypper install selinux-policy-devel

samba

apt-get install samba

yum install samba
samba-winbind-clients

zypper install samba samba-client