Software

The following prerequisites must be met to install the ESET PROTECT Server on Windows:

You must have a valid license.

 

Microsoft .NET Framework 4 must be installed; you can install it using the Add Roles and Features Wizard.

 

The ESET PROTECT Web Console requires Java/OpenJDK (64-bit).

 

warning

Warning

Starting January 2019, Oracle JAVA SE 8 public updates for business, commercial or production use require a commercial license. If you do not purchase a JAVA SE subscription, you can transition to a no-cost alternative. See the supported versions of JDK.

 

ESET PROTECT supports two types of database servers: MS SQL and MySQL. We recommend that you use Microsoft SQL Server Express 2019 included with ESET PROTECT All-in-one installer for Windows. If you already have a database server and you want to use it for ESET PROTECT, make sure it meets database requirements.

 

The ESET PROTECT Web Console can be run in the following web browsers:

oMozilla Firefox

oMicrosoft Edge

oGoogle Chrome

oSafari

oOpera

note

Note

For the best experience with the ESET PROTECT Web Console we recommend that you keep your web browsers updated.

If you use Internet Explorer, ESET PROTECT Web Console will notify you that you are using an unsupported web browser.