ESET Remote Deployment Tool - Fehlerbehebung
Das ESET Remote Deployment Tool ist auf der ESET-Webseite kostenlos als eigenständige ESET PROTECT On-Prem-Komponente verfügbar. Das Deployment Tool eignet sich hauptsächlich für die Bereitstellung in kleinen und mittelgroßen Netzwerken und wird mit Administratorberechtigungen ausgeführt.
Das ESET Remote Deployment Tool stellt ESET Management Agenten auf Clientcomputern mit unterstützten Microsoft Windows-Betriebssystemen bereit. |
Die folgende Tabelle enthält eine Liste von Fehlermeldungen und Gründen, mit denen die Bereitstellung fehlschlagen kann:
Fehlermeldung |
Mögliche Ursachen |
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Der Netzwerkpfad wurde nicht gefunden (Fehlercode 0x35) |
•Client ist im Netzwerk nicht erreichbar, Firewall blockiert die Kommunikation •Die eingehenden Ports 135, 137, 138, 139 und 445 sind in der Firewall des Clients oder in der Windows Firewall nicht geöffnet: Die Ausnahme für eingehende Datei- und Druckerfreigabe ist nicht gesetzt •Client-Hostname konnte nicht aufgelöst werden, verwenden Sie gültige FQDN-Computernamen |
Zugriff verweigert (Fehlercode 0x5) Benutzername oder Passwort ist falsch (Fehlercode 0x52e) |
•Wenn Sie von einem Server in einer Domäne auf einen Client in der Domäne bereitstellen, geben Sie die Anmeldeinformationen eines Benutzers, der Mitglied der Gruppe „Domänen-Admins“ ist, im folgenden Format an: Domäne\DomänenAdmin •Wenn Sie von einem Server auf einen Client in einer anderen Domäne bereitstellen, deaktivieren Sie die Remote-UAC-Filterung auf dem Zielcomputer. •Wenn Sie von einem Server auf einen Client in einer anderen Domäne bereitstellen, geben Sie die Anmeldeinformationen eines lokalen Benutzers, der Mitglied der Gruppe „Administratoren“ ist, im Format „Admin“ an. Der Name des Zielcomputer wird automatisch vor den Anmeldenamen eingefügt. •Kein Passwort für Administratorkonto festgelegt •Unzureichende Zugriffsrechte •Verwaltungsfreigabe ADMIN$ ist nicht verfügbar •Verwaltungsfreigabe IPC$ ist nicht verfügbar •Einfache Dateifreigabe ist aktiviert |
Dieses Installationspaket wird auf der vorliegenden Prozessorarchitektur nicht unterstützt (Fehlercode 1633) |
Das Installationspaket wird auf dieser Plattform nicht unterstützt. Erstellen Sie das Installationspaket mit der richtigen Plattform (64-Bit- oder 32-Bit-Betriebssystem) in der ESET PROTECT-Web-Konsole und laden Sie es herunter. |
Das Semaphorezeitlimit ist abgelaufen |
Ein Client kann nicht auf die Netzwerkfreigabe mit dem Bereitstellungspaket zugreifen, da SMB 1.0 in der Freigabe deaktiviert ist. |
Führen Sie je nach möglicher Ursache die entsprechenden Schritte zur Fehlerbehebung aus:
Mögliche Ursache |
Fehlerbehebung |
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Client ist im Netzwerk nicht erreichbar |
Senden Sie einen Ping vom ESET PROTECT Server zum Client. Wenn Sie eine Antwort erhalten, versuchen Sie, sich remote beim Clientcomputer anzumelden (z. B. per Remote Desktop). |
Firewall blockiert die Kommunikation |
Überprüfen Sie die Firewall-Einstellungen auf Server und Client sowie ggf. in sämtlichen anderen Firewalls zwischen den beiden Computern. Nach der erfolgreichen Bereitstellung sind die Ports 2222 und 2223 nicht in der Firewall geöffnet. Vergewissern Sie sich, dass diese Ports in allen Firewalls zwischen den beiden Computern (Client und Server) geöffnet sind. |
Client-Hostname kann nicht aufgelöst werden |
Mögliche Maßnahmen bei DNS-Problemen: •Führen Sie den Befehl nslookup für die IP-Adresse bzw. den Hostnamen des Servers und/oder der Clients aus, auf denen Probleme bei der Agenten-Bereitstellung auftreten. Die Ergebnisse müssen mit den Informationen vom entsprechenden Computer übereinstimmen. Beispielsweise sollte der Befehl nslookup für einen Hostnamen auf die IP-Adresse aufgelöst werden, die mit dem Befehl ipconfig auf dem entsprechenden Host angezeigt wird. Führen Sie den Befehl nslookup auf den Clients und auf dem Server aus. •Überprüfen Sie die DNS-Einträge manuell auf Duplikate. |
Kein Passwort für Administratorkonto festgelegt |
Legen Sie ein zulässiges Passwort für das Administratorkonto fest (verwenden Sie keine leeren Passwörter). |
Unzureichende Zugriffsrechte |
Versuchen Sie, den Task für die Agenten-Bereitstellung mit den Anmeldedaten des Domänenadministrators auszuführen. Wenn sich der Clientcomputer in einer Arbeitsgruppe befindet, verwenden Sie auf diesem Computer das lokale Administratorkonto. Das Administratorbenutzerkonto muss aktiviert sein, um den Task „Agenten-Bereitstellung“ ausführen zu können. Sie können einen lokalen Benutzer erstellen, der Mitglied der Gruppe „Administratoren“ ist, oder das integrierte lokale Administratorkonto aktivieren. So aktivieren Sie das Administrator-Benutzerkonto: 1.Öffnen Sie als Administrator ein Eingabeaufforderungsfenster. 2.Geben Sie Sie den folgenden Befehl aus: net user administrator /active:yes |
Die Verwaltungsfreigabe ADMIN$ ist nicht verfügbar |
Auf dem Clientcomputer muss die freigegebene Ressource ADMIN$ aktiviert sein. Vergewissern Sie sich, dass sie in den anderen Freigaben enthalten ist (Start > Systemsteuerung > Verwaltung > Computerverwaltung > Freigegebene Ordner > Freigaben). |
Die Verwaltungsfreigabe IPC$ ist nicht verfügbar |
Vergewissern Sie sich, dass der Server auf IPC$ zugreifen kann, indem Sie in der Eingabeaufforderung auf dem Server den folgenden Befehl ausführen: net use \\clientname\IPC$. Ersetzen Sie dabei clientname durch den Namen des Zielcomputers. |
Einfache Dateifreigabe ist aktiviert |
Wenn Sie die Fehlermeldung Zugriff verweigert erhalten und in einer gemischten Umgebung aus Domänen und Arbeitsgruppen arbeiten, deaktivieren Sie auf allen Computern, auf denen Probleme bei der Agenten-Bereitstellung auftreten, die Funktion Einfache Dateifreigabe verwenden bzw. Freigabe-Assistent verwenden. Gehen Sie unter Windows 11 beispielsweise folgendermaßen vor: •Klicken Sie auf Start, geben Sie Datei-Explorer in das Suchfeld ein, und klicken Sie auf Datei-Explorer-Optionen. Klicken Sie auf die Registerkarte Ansicht und blättern Sie unter Erweiterte Einstellungen nach unten. Deaktivieren Sie das Kontrollkästchen Freigabe-Assistent verwenden. |