升級已在 Linux 的容錯移轉叢集中安裝的 ERA

如果已將 ESMC 伺服器安裝在 Linux 容錯移轉叢集中,而且想要升級安裝,請繼續進行對應步驟。

您要升級具有 ERA Proxy 的環境?

從 ERA 6.5 版 (或更新版本) 手動升級為最新版本的 ESMC

1.在 Conga (叢集管理 GUI) 的 [服務群組] 下停用 EraService,並確保兩個節點上的 ERA Agent 和 ERA 伺服器均已停止。

2.執行下列步驟,升級節點 1 上的 ERA 伺服器:

a.將共用儲存裝載到此節點

b.將 ERA 伺服器手動升級為最新版本,作法為以 root 或 sudo 身分執行伺服器安裝指令碼 server-linux-x86_64.sh

c.使用 /opt/eset/RemoteAdministrator/Server/setup/eracluster_server 中的新叢集指令碼取代位於 /usr/share/cluster/eracluster_server.sh 的舊叢集指令碼。請勿變更 eracluster_server.sh.

d.在升級之後停止 ESMC 伺服器服務 (stop eraserver)。

e.重新命名下列 2 個檔案來停用 ESMC 伺服器自動啟動:

i.mv /etc/init/eraserver.conf /etc/init/eraserver.conf.disabled

ii.mv /etc/init/eraserver-xvfb.conf /etc/init/eraserver-xvfb.conf.disabled

f.將共用儲存從此節點取消裝載。

3.重複這些步驟以升級節點 2 上的 ERA 伺服器。

4.在 Conga (叢集管理 GUI) 的 [服務群組] 下啟動 EraService

5.升級所有叢集節點上的 ERA 代理程式

6.查看 ESMC Web Console 了解是否所有節點都已連接並顯示為最新版本。