代理程式先決條件 - Linux

若要將 ESET Management 代理程式元件安裝在 Linux 上,您必須符合下列先決條件:

伺服器協助式代理程式安裝先決條件

伺服器電腦必須可透過網路存取,且已安裝 ESMC 伺服器ESMC Web Console

我們建議您使用最新的 OpenSSL 版本 (1.1.1)。最低支援的 OpenSSL 版本為 openssl-1.0.1e-30。可以有多種版本的 OpenSSL 同時安裝在一個系統上。您的系統上必須至少有一個支援的版本。

o您可以使用命令 openssl version 來顯示目前的預設版本。

o您可以列出存在於您系統上所有版本的 OpenSSL。請參閱使用命令 sudo find / -iname *libcrypto.so* 列出的檔案名稱結尾

oFedora Linux 使用者應使用 compat-openssl10 套件。

離線代理程式安裝先決條件

伺服器電腦必須可透過網路存取,且已安裝 ESMC 伺服器

必須有代理程式的憑證

必須有伺服器憑證授權單位公用金鑰檔案

我們建議您使用最新的 OpenSSL 版本 (1.1.1)。最低支援的 OpenSSL 版本為 openssl-1.0.1e-30。可以有多種版本的 OpenSSL 同時安裝在一個系統上。您的系統上必須至少有一個支援的版本。

o您可以使用命令 openssl version 來顯示目前的預設版本。

o您可以列出存在於您系統上所有版本的 OpenSSL。請參閱使用命令 sudo find / -iname *libcrypto.so* 列出的檔案名稱結尾

oFedora Linux 使用者應使用 compat-openssl10 套件。

 

note

注意

若為 Linux CentOS,建議安裝 policycoreutils-devel 套件。執行此命令來安裝套件:

yum install policycoreutils-devel