Compatibility

Version compatibility between ESA Core (Authentication Server) and the other components (Windows Login, Remote Desktop Protection, IIS, ADFS, RADIUS, ADUC) of ESET Secure Authentication has been improved. The tables below show which versions of ESA core, ESA Component and Management Console (MMC) are cross-compatible.

Compatibility table - component connecting to Authentication Server 2.8

Component

Component v2.4

Component v2.5

Component v2.6

Component v2.7

Component v2.8

Windows Login

OK*

OK*

OK

OK

OK

RDP

OK*

OK*

OK

OK

OK

AD FS

OK*

OK*

OK

OK

OK

IIS

FAIL

FAIL

OK

OK

OK

Management Tools (ADUC, MMC)

FAIL

FAIL

FAIL

FAIL

OK

* Works if the component was registered (used) with the corresponding version of Authentication Server (2.4 or 2.5) prior to upgrading Authentication Server to version 2.8.

note

Note

You cannot register newer component versions with an older server version. The connection will fail due to compatibility issues and you will receive a notification of the error.