Tâche de mise à niveau des composants

Ce chapitre contient les sections suivantes :

Recommandations

Liste des composants mis à jour

Avant la mise à niveau

Procédure relative à la tâche Mise à niveau des composants Remote Administrator

Dépannage

 

Recommandations :

Il est recommandé d'utiliser la tâche Mise à niveau des composants, disponible dans ERA Web Console, pour mettre à niveau votre infrastructure ERA. L'exemple suivant illustre la configuration de la tâche Mise à niveau des composants Remote Administrator pour effectuer la mise à niveau d'ERA version 6.1.x ou ultérieure vers ERA version 6.5.

validation-status-icon-warning IMPORTANT : sauvegardez tous les certificats (certificats d'autorité de certification, serveur, proxy et agent) pour effectuer cette opération. Pour sauvegarder vos certificats :

1.Exportez les certificats de l'autorité de certification d'un ancien ERA Server vers un fichier .der et enregistrez-les dans un stockage externe.

2.Exportez les certificats d'homologues (pour ERA Agent, ERA Server, ERA Proxy) et le fichier .pfx de clé privée depuis un ancien ERA Server et enregistrez-les dans un stockage externe.

Lors de l'exécution de cette tâche, sélectionnez le groupe Tous comme cible pour que l'ensemble de l'infrastructure ERA soit mise à niveau.

 

Liste des composants mis à niveau :

ERA Server

ERA Agent (la tâche met à jour tous les ordinateurs du réseau avec les agents ERA Agent installés s'ils sont sélectionnés comme cibles pour la tâche)

ERA Proxy

Console Web ERA : s'applique uniquement lorsque ce composant a été installé à l'aide du programme d'installation ERA tout-en-un ou de l'appliance virtuelle ERA et de n'importe quelle distribution Linux (à condition que le dossier d'installation figure dans /var/lib/tomcat8/webapps/, /var/lib/tomcat7/webapps/, /var/lib/tomcat6/webapps/, /var/lib/tomcat/webapps/])

ERA Connecteur de périphérique mobile (de la version 6.2.11.0 vers ERA version 6.5.)

Les composants suivants doivent être manuellement mis à niveau :

Apache Tomcat (il est vivement recommandé de mettre à jour Apache Tomcat ; consultez la section Mise à niveau d'Apache Tomcat)

Apache HTTP Proxy (peut s'effectuer à l'aide du programme d'installation tout-en-un ; consultez la section Mise à niveau d'Apache HTTP Proxy)

ERA Rogue Detection Sensor

 

Avant la mise à niveau :

validation-status-icon-errorsi la mise à niveau des composants échoue sur un ordinateur qui exécute ERA Server ou la console Web, vous risquez de ne pas pouvoir vous connecter à distance à la console Web. Il est conseillé de configurer un accès physique à l'ordinateur serveur avant d'effectuer cette mise à niveau. Si un accès physique à l'ordinateur est impossible, vérifiez que vous pouvez vous y connecter avec des privilèges administratifs à l'aide du Bureau à distance. Il est recommandé de sauvegarder les bases de données d'ERA Server et du Connecteur de périphérique mobile avant d'effectuer cette opération. Pour sauvegarder l'appliance virtuelle, créez un instantané ou clonez la machine virtuelle.

hmtoggle_plus0Vous effectuez la mise à niveau depuis ERA version 6.1.x ?
hmtoggle_plus0Une instance ERA Server est installée sur un cluster de basculement
hmtoggle_plus0ERA Agent est installé sur les clients Linux qui s'exécutent avec systemd dans votre infrastructure ?
hmtoggle_plus0Instructions importantes à respecter avant la mise à niveau du proxy HTTP Apache sur Microsoft Windows
hmtoggle_plus0Instructions importantes à respecter avant la mise à niveau du proxy HTTP Apache sur l'appliance virtuelle

 

Reportez-vous à la rubrique d'aide en ligne Mettre à jour les composants d'ESET Remote Administrator. Pour obtenir un autre guide de mise à niveau d'ESET Remote Administrator vers la dernière version (6.x), consultez l'article de la base de connaissances.

 

Dépannage :

Vérifiez si vous pouvez accéder au référentiel ERA depuis un ordinateur mis à niveau.

Une nouvelle exécution de la tâche Mettre à jour les composants d'ESET Remote Administrator ne fonctionnera pas si un composant a déjà été mis à niveau vers une nouvelle version.

S'il n'existe pas de motif clair pour expliquer l'échec, effectuez une mise à niveau manuelle des composants. Consultez nos instructions pour Windows ou Linux.

Sur les ordinateurs Linux qui utilisent systemd en tant que gestionnaire de service, cette tâche peut ne pas se terminer correctement. Les distributions Linux avec scripts init SysV ou upstart ne sont pas affectées.

Consultez les informations générales de dépannage pour accéder à d'autres suggestions de résolution des problèmes.